plivo.com DNS issue
Incident Report for Plivo
Resolved
All of our services are back up using most DNS Providers globally. If you still see any service down, we recommend you switch your DNS lookup to GoogleDNS or OpenDNS.
We will share a detailed Postmortem in the next 72 hours.
Posted Apr 24, 2017 - 13:40 UTC
Identified
plivo.com Domain/Subdomain Outage
Due to an error with our domain registrar “plivo.com” and all its subdomains were unreachable for the last 12 hours.
We have isolated and resolved the configuration error with our domain provider, however we expect the change to propagate globally within next 3-12 hours. (April 24th, 18 hrs UTC)
In the interim we have replicated all our services on “plivo.io” domain to ensure there is no service downtime. We have detailed the recommended workaround about the same below.
We apologize for the inconvenience.
Meanwhile if you have any issues or questions regarding this incident, please contact us at: https://support.plivo.com

IMPORTANT:
Recommended Workaround (requires code change):
We have mapped all our “plivo.com” subdomains to “plivo.io”. We recommend that you make changes to your current app to use plivo.io to ensure uptime of service till further updates:

API : you can use api.plivo.io instead of api.plivo.com

SIP registrar : you can use phone.plivo.io instead of phone.plivo.com

WebSDK version 1 : https://s3.amazonaws.com/plivosdk-backup/sdk/browser/v1/plivo.min.js

WebSDK version 2 : https://s3.amazonaws.com/plivosdk-backup/sdk/browser/v2/plivo.min.js

Dashboard: manage.plivo.io instead of manage.plivo.com

Custom Inbound Carriers:
sbc.plivo.io
eu.sbc.plivo.io
asia.sbc.plivo.io
au.sbc.plivo.io
sa.sbc.plivo.io

Application SIP server : you can use app.plivo.io instead of app.plivo.com

You can find the complete document below:
https://docs.google.com/document/u/1/d/1hHIGcDQYb7nlL09-K1IOG_6mnVSDIHw_7D62X9RAneE/pub


We have published a doc online with more details:
https://docs.google.com/document/u/1/d/1hHIGcDQYb7nlL09-K1IOG_6mnVSDIHw_7D62X9RAneE/pub
Posted Apr 24, 2017 - 11:33 UTC