Delivery delay on Outbound Short-Code SMS towards US Cellular phone numbers : Verizon, T-Mobile & Sprint
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Aug 04, 2020 - 09:10 UTC
Investigating
We are currently observing outbound SMS delivery delays for a small segment of SMS towards US verizon, t-mobile & sprint phone numbers. All other SMS services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#195253
Posted Aug 04, 2020 - 05:40 UTC