Delivery delays on inbound SMS failure towards a small subset of US & Canada longcode numbers.
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted May 12, 2020 - 02:23 UTC
Update
We are continuing to investigate this issue.
Posted May 11, 2020 - 23:18 UTC
Investigating
We are currently observing inbound SMS delivery delays towards a small subset of US numbers .
We're actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
Posted May 11, 2020 - 21:41 UTC