Delivery delays on inbound MMS towards US & Canada Tollfree numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted May 23, 2020 - 20:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2020 - 18:40 UTC
Investigating
Our carrier partner is observing minor inbound MMS delivery delays towards the US & Canada phone numbers. A small percentage of phone numbers may experience failures.

We're actively working with our carrier partner to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#190687
Posted May 23, 2020 - 17:05 UTC