-

Intermittent Inbound SMS and MMS Delivery failures towards US and Canada

Incident Report for Plivo

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 08:06 UTC

Update

We are continuing to investigate this issue.
Posted Feb 25, 2025 - 05:46 UTC

Update

We are continuing to investigate this issue.
Posted Feb 22, 2025 - 07:21 UTC

Investigating

Dear Valued Customer,

We are currently experiencing intermittent issues affecting inbound SMS and MMS delivery to the US and Canada. All other services remain fully operational.

Our team is actively investigating and working to resolve this issue as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/hc/en-us
Posted Feb 21, 2025 - 19:14 UTC
This incident affected: Carrier Partners: Messaging API (Longcode SMS, USA & Canada, MMS, USA & Canada).