Delivery delay on two-way SMS towards US & Canada phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Incident lasted from 16 January 2020 18:48 UTC - 16 January 2020 20:01 UTC.
Posted Jan 16, 2020 - 22:00 UTC
Investigating
We are currently observing two-way SMS delivery delays for a small segment of SMS towards the US & Canada phone numbers.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#180795
Posted Jan 16, 2020 - 21:51 UTC