Scheduled Maintenance : Service degradation on incoming calls in St. Cloud (Minnesota) & Fargo (North Dakota) in the US
Scheduled for Jun 23, 12:00 - 18:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted 1 day ago. May 17, 2019 - 19:59 UTC
Scheduled
One of our carriers in St. Cloud (Minnesota) & Fargo (North Dakota) in the US is performing a planned maintenance on their service.

When is the maintenance?
23rd June 2019 08:00 Hrs EDT - 23rd June 2019 14:00 Hrs EDT
23rd June 2019 12:00 Hrs UTC - 23rd June 2019 06:00 Hrs UTC

What services will be affected?
Inbound voice

What is the impact?
You may experience some delays in delivery.

If you have any questions, please feel free to reach out to our support team.
Please click on the following link to submit a support ticket: https://support.plivo.com/support/tickets/new
#159963
Posted 1 day ago. May 17, 2019 - 19:51 UTC
This scheduled maintenance affects: Voice API (PSTN).