Delivery delay on two-way SMS towards the US and Canada phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved
Posted Jan 16, 2020 - 21:38 UTC
Identified
The issue has been implemented and a fix is being implemented
Posted Jan 16, 2020 - 19:40 UTC
Investigating
We are currently observing two-way SMS delivery delays for a small segment of SMS towards the US and Canada phone numbers.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#180797
Posted Jan 16, 2020 - 19:12 UTC