Call Connection Delays on Inbound Voice towards Canada (Montreal) Phone numbers
Incident Report for Plivo
Resolved
All systems are operating normally at this time. The incident has been resolved.
Posted Oct 17, 2018 - 16:08 UTC
Investigating
Dear Valued Customers,

We are currently observing minor inbound voice call connection delays towards Canada (Montreal) phone numbers. A small percentage of phone numbers may experience call connection delays.

We're actively working with our carrier partner to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
Posted Oct 17, 2018 - 15:36 UTC
This incident affected: Voice API (PSTN Calls).