Call failures on inbound voice towards Spain phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Nov 08, 2019 - 22:59 UTC
Investigating
Our carrier partner is observing minor inbound voice call failures towards Spain phone numbers. A small percentage of phone numbers may experience call failures.

We're actively working with our carrier partner to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#174791
Posted Nov 08, 2019 - 22:44 UTC