Delivery delay on two-way SMS towards the US phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Jan 08, 2020 - 15:50 UTC
Investigating
We are currently observing two-way regular SMS delivery delays for a small segment of SMS towards the US phone numbers. All other SMS services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#180280
Posted Jan 08, 2020 - 15:06 UTC