Incident report : Service impact for Inbound calls to Indonesia numbers with 62 prefix
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Oct 16, 2018 - 21:47 UTC
Investigating
A supplier outage in Indonesia is causing incoming call failure to numbers with 62 prefix.
We're in touch with the carrier to get this resolved asap.

For any question, please contact Plivo Support https://support.plivo.com/support/home
Posted Oct 16, 2018 - 20:32 UTC