Call connection delays on inbound voice towards Italy (in the area of Napoli) phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted 24 days ago. Apr 24, 2019 - 19:27 UTC
Investigating
Our carrier partner is observing minor inbound voice call connection delays towards Italy (in the area of Napoli) phone numbers. A small percentage of phone numbers may experience call connection delays.

We're actively working with our carrier partner to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#145348
Posted 25 days ago. Apr 24, 2019 - 13:57 UTC
This incident affected: Voice API (PSTN).