Call failures on inbound voice towards Spain phone numbers in Valencia area
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted 9 days ago. May 10, 2019 - 07:35 UTC
Investigating
Our carrier partner is observing inbound voice call failures towards Spain phone numbers in Valencia area A small percentage of phone numbers may experience call failures.

We're actively working with our carrier partner to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
Posted 10 days ago. May 09, 2019 - 10:44 UTC
This incident affected: Voice API (PSTN).