Delay in delivery report on Inbound and Outbound SMS towards the US and Canada toll free numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Mar 24, 2020 - 08:41 UTC
Investigating
We are currently observing delivery report delays for a small segment of the US and Canada tollfree numbers.

We're actively working with our carrier to get this issue resolved as soon as possible.

If you have any questions, please feel free to reach out to our support team.
Please click on the following link to submit a support ticket: https://support.plivo.com/support/home
#186567
Posted Mar 24, 2020 - 08:34 UTC