Inbound call failures to some US Phone numbers
Incident Report for Plivo
Resolved
We can confirm that all inbound calls to US & Canada DIDs have fully recovered and traffic is processing as expected. We will continue to monitor.
Posted Mar 14, 2018 - 22:29 UTC
Monitoring
We are seeing calls connecting to the DIDs again, We will continue to monitor for stability
Posted Mar 14, 2018 - 22:14 UTC
Update
Canada DIDs are also impacted. Our carrier partner is continuing to resolve the issue.
Posted Mar 14, 2018 - 22:02 UTC
Identified
We are experiencing inbound call failures for calls to some US DIDs. We are actively working with our carrier to resolve this issue.
Posted Mar 14, 2018 - 21:00 UTC