Intermittent Inbound DID call failures on the Voice API and Zentrunk towards US West region
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Sep 11, 2020 - 18:06 UTC
Monitoring
Our engineers have confirmed that the services have been restored and are working normally. We will continue to monitor the situation and provide another update as soon as possible.
Posted Sep 11, 2020 - 17:47 UTC
Investigating
We are currently experiencing Intermittent Inbound DID call failures on Plivo Voice API and Zentrunk on calls towards US West region. Our engineers are actively working on it to re-establish services.

Please contact Plivo Support for any question or concern,
Support portal: https://support.plivo.com/support/home
Posted Sep 11, 2020 - 17:12 UTC
This incident affected: Voice API (PSTN Calls).