SMS 10DLC delivery delay towards T-mobile numbers in US
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 13:01 UTC
Investigating
Dear Valued Customer,

We are currently observing a 10DLC SMS delivery delay towards the T-Mobile numbers in US. All other services are operating normally.

We are working with our carrier partner to resolve this issue as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/hc/en-us
#60303
Posted Apr 15, 2024 - 23:14 UTC
This incident affected: Carrier Partners: Messaging API (Longcode SMS, USA & Canada).