Payments and Auto-recharge delays
Incident Report for Plivo
Resolved
The issue has been resolved.
We are back, fully functional now. All stuck payments also got cleared now.
Posted May 17, 2017 - 15:02 UTC
Identified
Our payment provider is currently experiencing technical issue due to which our payments are getting stuck. We are working with them to resolve the issue as early as possible. Will keep you posted.
Posted May 17, 2017 - 13:36 UTC