Delivery delay on two-way SMS towards US & Canada toll-free phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Feb 14, 2020 - 05:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2020 - 05:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 14, 2020 - 05:13 UTC
Investigating
We are currently observing two-way SMS delivery delays for a small segment of SMS towards the US & Canada phone numbers.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#183641
Posted Feb 14, 2020 - 05:09 UTC