Delivery delays on outbound & inbound SMS to US Cellular from US Toll-free numbers
Incident Report for Plivo
Resolved
This incident is resolved, and all services are operational.
Posted Nov 14, 2018 - 21:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2018 - 19:01 UTC
Identified
Carrier partner has identified the issue with Message Latency affecting US Cellular Customers.
We are actively working with our carrier to get this issue resolved as soon as possible.
Posted Nov 14, 2018 - 18:46 UTC
Investigating
We are currently observing outbound & inbound SMS delivery delays from a small segment of toll-free SMS towards US Cellular. All other SMS services are operating normally.
We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
Posted Nov 14, 2018 - 18:15 UTC