Delivery delay on Inbound SMS towards US & Canada phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved
Posted Nov 20, 2019 - 01:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results
Posted Nov 20, 2019 - 01:02 UTC
Investigating
We are currently observing Inbound SMS delivery delays for a small segment of SMS towards US & Canada phone numbers. All other SMS services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#175922
Posted Nov 20, 2019 - 00:30 UTC
This incident affected: SMS API (Regular SMS) and Phone Numbers.