Inbound calls to Argentina numbers affected
Incident Report for Plivo
Resolved
The issue with inbound calls to our Argentina numbers has been resolved by our local carrier.
Posted Apr 18, 2018 - 00:22 UTC
Investigating
We are experiencing issues with inbound calls to few Argentina numbers. We are working with our carrier to get this issue resolved as soon as possible. We will keep the status page updated.
Posted Apr 17, 2018 - 23:06 UTC