Incident Report : Delivery Degradation of Outbound SMS in Bhutan - TashiCell (Tashi InfoComm Ltd)
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted May 23, 2018 - 08:25 UTC
Investigating
Our Carrier in Bhutan is experiencing degradation in delivery towards TashiCell (Tashi InfoComm Ltd) ( NNC: 40277 ) network, Bhutan. You may experience irregular delivery with inconsistent delivery times when sending to this network.

We are following up with our Carrier to resolve this issue as soon as possible however, there is no estimated time of resolution.

We appreciate your patience and understanding and as always, if you have any questions or issues related to the incident, you can reach out to our Support team.
Support portal: https://support.plivo.com/support/home.
Posted May 23, 2018 - 07:20 UTC