Call Connection Delays on Inbound Voice towards Davenport, Iowa (IA) Phone numbers.
Incident Report for Plivo
Resolved
This incident is resolved, and the services are operational.
Posted Nov 27, 2018 - 03:46 UTC
Monitoring
Our carrier partner has implemented a fix and monitoring the results. We will keep you posted.
Posted Nov 27, 2018 - 02:31 UTC
Update
A fix has been implemented and we are monitoring the results.
Posted Nov 27, 2018 - 02:22 UTC
Investigating
We are currently observing minor inbound voice call connection delays towards Davenport, Iowa (IA) phone numbers. A small percentage of phone numbers may experience call connection delays.

We're actively working with our carrier partner to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
Posted Nov 26, 2018 - 21:59 UTC
This incident affected: Voice API (PSTN Calls).