Delivery delay on Toll-Free SMS towards US & Canada phone numbers.
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Mar 24, 2020 - 07:05 UTC
Investigating
We are currently observing two-way SMS delivery delays for a small segment of SMS towards the US & Canada phone numbers.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#186557
Posted Mar 24, 2020 - 07:04 UTC