Delivery delays on outbound SMS in US towards US Cellular phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Aug 02, 2020 - 01:49 UTC
Investigating
We are currently observing outbound SMS delivery delays in the US towards US Cellular phone numbers. All other SMS services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#195184
Posted Aug 01, 2020 - 21:37 UTC