Call connection delays on inbound\outbound voice calls towards US phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Sep 07, 2023 - 22:07 UTC
Monitoring
Our carrier partner have confirmed that the services have been restored and are working normally. We will continue to monitor the situation and provide another update as soon as possible.
Posted Sep 07, 2023 - 18:14 UTC
Investigating
Dear Valued Customer,

One of our carrier partners currently observing inbound\outbound call connection delays for a small segment of phone numbers in the US. All other services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#37967
Posted Sep 07, 2023 - 17:05 UTC
This incident affected: Carrier Partners: Voice API (Voice, North America).