We are continuing to monitor for any further issues.
Posted Nov 12, 2024 - 20:46 UTC
Monitoring
Our carrier partner have confirmed that the services have been restored and are working normally. We will continue to monitor the situation and provide another update as soon as possible.
Posted Nov 12, 2024 - 20:44 UTC
Investigating
Dear Valued Customer,
One of our carrier partners is currently observing outbound toll-free MMS delivery delays towards T-Mobile phone numbers in the US region. All other services are operating normally.
We are actively working with our carrier to get this issue resolved as soon as possible.