Inbound call failure towards US phone numbers in Henderson, CO
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 21:57 UTC
Update
We are continuing to investigate this issue.
Posted Sep 21, 2020 - 16:14 UTC
Update
We are continuing to investigate this issue.
Posted Sep 19, 2020 - 12:30 UTC
Investigating
Our carrier partner is observing minor inbound voice call failures towards US phone numbers in Henderson, CO. A small percentage of phone numbers may experience call failures.

We're actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#198167
Posted Sep 18, 2020 - 22:05 UTC