Delivery delay on inbound MMS towards the US and Canada phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Mar 31, 2021 - 17:21 UTC
Investigating
We are currently observing inbound MMS delivery delays for a small segment of MMS towards the US and Canada phone numbers. A small percentage of phone numbers may experience delivery delays in MMS services. All other services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
Posted Mar 31, 2021 - 17:18 UTC
This incident affected: Carrier Partners: Messaging API (MMS, USA & Canada).