Incident Report : Inbound calls failing for Spain DIDs
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Jul 04, 2018 - 04:30 UTC
Investigating
One of our carrier in Spain is experiencing network outage and investigating the issue. We're in constant touch with the carrier to get it resolved soon.

Affected services: Inbound calls to Spain DIDs

We appreciate your patience and understanding and as always, if you have any questions you can reach out to our Support team.

Support portal: https://support.plivo.com/support/home.
Posted Jul 04, 2018 - 02:13 UTC