Delivery delays on inbound MMS towards US & Canada numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Aug 01, 2020 - 22:31 UTC
Update
We are continuing to investigate this issue.
Posted Aug 01, 2020 - 21:26 UTC
Investigating
We are currently observing inbound MMS delivery delays for a small segment of US & Canada numbers.

We're actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
195183
Posted Aug 01, 2020 - 21:25 UTC
This incident affected: Phone Numbers.