Delay in processing 10DLC Campaign requests

Incident Report for Plivo

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 05:29 UTC

Investigating

Dear Valued Customer,

One of our carrier partners is currently experiencing delays in provisioning new campaigns. This may impact new 10DLC campaign registrations, which may cause issues when linking numbers to your 10DLC campaign. Please note that existing campaigns will not be affected.

We are actively working with our carrier partner to resolve this issue as quickly as possible.

If you have any questions, please contact Plivo Support.
Support portal: https://support.plivo.com/hc/en-us
#86841
Posted Feb 18, 2025 - 17:42 UTC
This incident affected: Carrier Partners: Messaging API (Longcode SMS, USA & Canada).