Delivery delays on two-way SMS towards US & Canada Toll-Free numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Mar 14, 2019 - 18:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2019 - 18:06 UTC
Investigating
We are currently observing two-way SMS delivery delays for a segment of US & Canada Toll-Free numbers.

We're actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#141682
Posted Mar 14, 2019 - 17:45 UTC