Delivery delay on two-way SMS towards the US and Canada phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Nov 19, 2019 - 22:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2019 - 17:01 UTC
Identified
We are currently observing two-way SMS delivery delays for a small segment of SMS towards the US and Canada phone numbers. All other SMS services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#175878
Posted Nov 19, 2019 - 16:38 UTC
This incident affected: SMS API (Tollfree SMS) and Phone Numbers.