Delivery delay on inbound/outbound toll-free SMS/MMS towards US and Canada phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 18:58 UTC
Investigating
Dear Valued Customer,

We are currently observing inbound/outbound toll-free SMS/MMS delivery delays for a small segment of SMS/MMS towards US and Canada phone numbers. All other services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#5073
Posted Apr 02, 2021 - 17:57 UTC
This incident affected: Carrier Partners: Messaging API (Toll-free SMS, USA & Canada, MMS, USA & Canada).