Outbound Call Failures

Incident Report for Plivo

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 16:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2026 - 13:45 UTC

Investigating

Dear Valued Customer,

We are currently experiencing a full outbound call outage. Our team is actively engaged and working to identify the root cause and restore service as quickly as possible.

We will share our next update within 30 minutes, or sooner if there is a material change.

For urgent concerns, please contact Plivo Support: https://support.plivo.com/hc/en-us
Posted Jul 02, 2026 - 13:40 UTC
This incident affected: Voice API (REST APIs and XML, PSTN Calls, Client Calls (Browser & Mobile), Conference, Recordings, Text-to-Speech, Transcription, Speech Recognition, Endpoint calls (SIP), BYOC, Answering Machine detection).