Delivery delays on inbound SMS towards Telcel Mexico
Incident Report for Plivo
Resolved
This incident is resolved, all services are operational.
Posted Nov 17, 2018 - 20:49 UTC
Investigating
We are currently observing inbound SMS delivery delays for a small segment of Mexico phone numbers.

We're actively working with our carrier to get this issue resolved as soon as possible.


Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
Posted Nov 17, 2018 - 18:12 UTC