Outbound MMS Failures on Toll-Free Numbers (US & Canada)

Incident Report for Plivo

Resolved

This incident has been resolved.
Posted Jul 11, 2026 - 09:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2026 - 09:32 UTC

Investigating

Dear Valued Customer,

We have identified an issue causing failures for outbound MMS messages sent from Toll-Free numbers (US & Canada). The failures are due to a connectivity issue with an upstream carrier partner, and affected messages are failing to be delivered. SMS traffic and MMS sent over other routes are not impacted.

Our team is actively engaged with the carrier partner to restore service. We will share a further update shortly.

If you have any questions or concerns regarding this incident, please contact Plivo Support.
Support portal: https://support.plivo.com/hc/en-us
Posted Jul 11, 2026 - 07:47 UTC
This incident affected: Messaging API (MMS API).