Call failures on inbound voice towards Iowa (Davenport/Bettendorf) phone numbers
Incident Report for Plivo
Resolved
The incident has been resolved.
Posted 8 days ago. Feb 12, 2019 - 11:13 UTC
Monitoring
A fix has been implemented and we are monitoring the result.
Posted 8 days ago. Feb 12, 2019 - 09:23 UTC
Investigating
Our carrier partner is observing minor inbound voice call failures towards Iowa (Davenport/Bettendorf) phone numbers. A small percentage of phone numbers may experience call failures.

We're actively working with our carrier partner to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#137676
Posted 8 days ago. Feb 12, 2019 - 06:31 UTC
This incident affected: Voice API (PSTN).