Delivery delay on inbound & outbound MMS towards US & Canada phone numbers.
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Mar 20, 2020 - 06:04 UTC
Investigating
We are currently observing inbound & outbound MMS delivery delays for a small segment of MMS towards the US & Canada phone numbers.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#186140
Posted Mar 19, 2020 - 19:53 UTC