Incident : Intermittent issues for few DID numbers in Spain
Incident Report for Plivo
Resolved
One of our Voice carrier was experiencing issue impacting calls to Plivo DID numbers in Spain. This could have caused intermittent issues on incoming calls to these numbers.

The issue has since been resolved.

Issue Start Time : 2018-04-11, 22:46 UTC
Issue Resolved Time : 2018-04-12, 04:46 UTC

Please reach out to Plivo Support at https://support.plivo.com/support/home
Posted Apr 12, 2018 - 09:27 UTC