Delivery delay on Toll-Free SMS towards Rogers subscribers in Canada
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 02:12 UTC
Investigating
We are currently observing Toll-Free SMS delivery delays towards Rogers subscribers in Canada.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#183825
Posted Feb 19, 2020 - 00:08 UTC