Toll Free SMS- Delays with Outbound and Inbound messages in US and Canada
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Jun 11, 2018 - 04:15 UTC
Investigating
One of our Toll Free carrier in US and Canada is investigating an issue causing delays in Outbound and Inbound Toll Free SMS.

We're working with the carrier to resolve this with minimal disruption of service.
We will keep this post updated with progress.

Please contact Plivo Support for any question or concern,
Support portal: https://support.plivo.com/support/home
Posted Jun 11, 2018 - 03:14 UTC