Delivery delay on inbound SMS & MMS towards US phone numbers in Saginaw, MI
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 13:39 UTC
Monitoring
Our engineers have confirmed that the services have been restored and are working normally. We will continue to monitor the situation and provide another update as soon as possible.
Posted Nov 18, 2021 - 11:23 UTC
Identified
Dear Valued Customer,

We are currently observing inbound SMS & MMS delivery delays for a small segment of SMS & MMS towards US phone numbers in Saginaw, MI. A small percentage of phone numbers may experience delivery delays in SMS & MMS services. All other services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#63942
Posted Nov 18, 2021 - 10:58 UTC
This incident affected: Carrier Partners: Messaging API (Longcode SMS, USA & Canada, MMS, USA & Canada).