Incident Report : A small subset of Incoming calls are impacted on DIDs in Italy
Incident Report for Plivo
Resolved
All DIDs from Italy (in the area of Cagliari) are now operational again.

Thank you and we appreciate your patience.
Posted Jun 08, 2018 - 18:30 UTC
Investigating
One of our carrier has notified us about a partial network outage in Italy (in the area of Cagliari) that might impact some of your DIDs.

We're in constant touch with our carrier to get this issue resolved as soon as possible.
Please contact Plivo Support for any question or concern,
Support portal: https://support.plivo.com/support/home
Posted Jun 08, 2018 - 09:09 UTC