Delay in Message Delivery from US Shortcode numbers to T-Mobile USA
Incident Report for Plivo
Resolved
Shortcode SMS delivery is restored to normal
Posted Mar 07, 2018 - 15:41 UTC
Investigating
One of our SMS carrier is experiencing issue causing delays in Outbound SMS delivery from Shortcode numbers to subscribers on T-Mobile USA. They are actively working to resolve this.
Posted Mar 07, 2018 - 11:21 UTC