Delivery delay on Inbound/Outbound MMS towards phone numbers in US and Canada
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Dec 25, 2024 - 17:17 UTC
Investigating
Dear Valued Customer,

Our carrier partner is currently observing Inbound/Outbound MMS delivery delays towards phone numbers in the US and Canada regions. All other services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/hc/en-us
#82254
Posted Dec 25, 2024 - 15:26 UTC
This incident affected: Carrier Partners: Messaging API (MMS, USA & Canada).