Delivery delay on Outbound toll-free MMS towards US phone numbers
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Feb 04, 2025 - 17:00 UTC
Identified
Our carrier partner have identified the issue and they are working to implement a solution. We will provide an update as soon as we have additional information.
Posted Feb 04, 2025 - 15:02 UTC
Investigating
Dear Valued Customer,

One of our carrier partners is currently observing outbound toll-free MMS delivery delays in the US region. All other services are operating normally.

We are actively working with our carrier to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/hc/en-us
#85292
Posted Feb 04, 2025 - 14:42 UTC
This incident affected: Carrier Partners: Messaging API (MMS, USA & Canada).